Skip to content

← Actionable
Critical, CVSS 10.0

org.postgresql:postgresql vulnerable to SQL Injection via line comment generation

CVE-2024-1597GHSA-24rp-q3w6-vc56

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.postgresql:postgresql 42.7.2, 42.6.1, 42.5.5, 42.4.4, 42.3.9, 42.2.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.postgresql:postgresql

    Affected
    < 42.2.28>= 42.3.0, < 42.3.9>= 42.4.0, < 42.4.4>= 42.5.0, < 42.5.5>= 42.6.0, < 42.6.1>= 42.7.0, < 42.7.2
    Fixed in
    42.2.28, 42.5.5, 42.7.2, 42.6.1, 42.4.4, 42.3.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-1597: 4.81% estimated exploitation activity in the next 30 days; percentile 91.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact SQL injection is possible when using the non-default connection property preferQueryMode=simple in combination with application code that has a vulnerable SQL that negates a parameter value. There is no vulnerability in the driver when using the default query mode. Users that do not override the query mode are not impacted. Exploitation To exploit this behavior the following conditions must be met: 1. A placeholder for a numeric value must be immediately preceded by a minus (i.e. -) 1. There must be a second placeholder for a string value after the first placeholder on the same line. 1. Both parameters must be user controlled. The prior behavior of the driver when operating in simple query mode would inline the negative value of the first parameter and cause the resulting line to be treated as a -- SQL comment. That would extend to the beginning of the next parameter and cause the quoting of that parameter to be consumed by the comment line. If that string parameter includes a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-24rp-q3w6-vc56

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-1597

Advisory: org.postgresql:postgresql vulnerable to SQL Injection via line comment generation
IDs: CVE-2024-1597, GHSA-24rp-q3w6-vc56
Record: https://patchnext.com/advisories/cve-2024-1597 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.postgresql:postgresql 42.7.2, 42.6.1, 42.5.5, 42.4.4, 42.3.9, 42.2.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.postgresql:postgresql: affected < 42.2.28; >= 42.3.0, < 42.3.9; >= 42.4.0, < 42.4.4; >= 42.5.0, < 42.5.5; >= 42.6.0, < 42.6.1; >= 42.7.0, < 42.7.2; fixed in 42.2.28, 42.5.5, 42.7.2, 42.6.1, 42.4.4, 42.3.9

## Suggested inspection (read-only)
- Maven org.postgresql:postgresql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.postgresql:postgresql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-24rp-q3w6-vc56 (GitHub-reviewed advisory GHSA-24rp-q3w6-vc56 lists affected ranges: Maven org.postgresql:postgresql >=0 =42.3.0 =42.4.0 =42.5.0 =42.6.0 =42.7.0 <42.7.2)

Commands are suggestions: review each one before running it.

Loading voting…