Skip to content

← Actionable
High, CVSS 7.5amended

gradio vulnerable to Path Traversal

CVE-2024-1561GHSA-g9cj-cfpp-4g2x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 4.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gradio

    Affected
    < 4.13.0
    Fixed in
    4.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-1561: 9.31% estimated exploitation activity in the next 30 days; percentile 95.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in gradio-app/gradio, where the /componentserver endpoint improperly allows the invocation of any method on a Component class with attacker-controlled arguments. Specifically, by exploiting the moveresourcetoblockcache() method of the Block class, an attacker can copy any file on the filesystem to a temporary directory and subsequently retrieve it. This vulnerability enables unauthorized local file read access, posing a significant risk especially when the application is exposed to the internet via launch(share=True), thereby allowing remote attackers to read files on the host machine. Furthermore, gradio apps hosted on huggingface.co are also affected, potentially leading to the exposure of sensitive information such as API keys and credentials stored in environment variables.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g9cj-cfpp-4g2x

  2. Revision 1 · created ·

    Published from osv record GHSA-g9cj-cfpp-4g2x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-1561

Advisory: gradio vulnerable to Path Traversal
IDs: CVE-2024-1561, GHSA-g9cj-cfpp-4g2x
Record: https://patchnext.com/advisories/cve-2024-1561 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio 4.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio: affected < 4.13.0; fixed in 4.13.0

## Suggested inspection (read-only)
- `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g9cj-cfpp-4g2x (OSV record GHSA-g9cj-cfpp-4g2x lists affected ranges: PyPI gradio >=0 <4.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g9cj-cfpp-4g2x (GitHub-reviewed advisory GHSA-g9cj-cfpp-4g2x lists affected ranges: PyPI gradio >=0 <4.13.0)

Commands are suggestions: review each one before running it.

Loading voting…