Skip to content

← Actionable
Medium, CVSS 5.3amended

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') in tornado

CVE-2024-14029GHSA-753j-mpmx-qq6g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    <= 6.4.0
    Fixed in
    6.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-14029: 0.36% estimated exploitation activity in the next 30 days; percentile 29.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When Tornado receives a request with two Transfer-Encoding: chunked headers, it ignores them both. This enables request smuggling when Tornado is deployed behind a proxy server that emits such requests. Pound) does this. PoC 0. Install Tornado. 1. Start a simple Tornado server that echoes each received request's body: 2. Send a valid chunked request: 3. Observe that the response is as expected: 4. Send a request with two Transfer-Encoding: chunked headers: 5. Observe the strange response: This is because Tornado believes that the request has no message body, so it tries to interpret 1\r\nZ\r\n0\r\n\r\n as its own request, which causes a 400 response. With a little cleverness involving chunk-exts, you can get Tornado to instead respond 405, which has the potential to desynchronize the connection, as opposed to 400 which should always result in a connection closure. Impact Anyone using Tornado behind a proxy that forwards requests containing multiple Transfer-Encoding: chunked…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-753j-mpmx-qq6g

  2. Revision 1 · created ·

    Published from osv record GHSA-753j-mpmx-qq6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-14029

Advisory: Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') in tornado
IDs: CVE-2024-14029, GHSA-753j-mpmx-qq6g
Record: https://patchnext.com/advisories/cve-2024-14029 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected <= 6.4.0; fixed in 6.4.1

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-753j-mpmx-qq6g (OSV record GHSA-753j-mpmx-qq6g lists affected ranges: PyPI tornado >=0 <6.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-753j-mpmx-qq6g (GitHub-reviewed advisory GHSA-753j-mpmx-qq6g lists affected ranges: PyPI tornado >=0 <=6.4.0)

Commands are suggestions: review each one before running it.

Loading voting…