LlamaIndex Uncontrolled Resource Consumption vulnerability
CVE-2024-12910GHSA-jvpf-xf32-2w4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index
- Affected
- < 0.12.9
- Fixed in
- 0.12.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jvpf-xf32-2w4q lists affected ranges: PyPI llama-index >=0 <0.12.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jvpf-xf32-2w4q lists affected ranges: PyPI llama-index >=0 <0.12.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-12910: 0.70% estimated exploitation activity in the next 30 days; percentile 53.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the KnowledgeBaseWebReader class of the run-llama/llamaindex repository, version latest, allows an attacker to cause a Denial of Service (DoS) by controlling a URL variable to contain the root URL. This leads to infinite recursive calls to the getarticleurls method, exhausting system resources and potentially crashing the application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jvpf-xf32-2w4q
- Revision 1 · created ·
Published from osv record GHSA-jvpf-xf32-2w4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-12910 Advisory: LlamaIndex Uncontrolled Resource Consumption vulnerability IDs: CVE-2024-12910, GHSA-jvpf-xf32-2w4q Record: https://patchnext.com/advisories/cve-2024-12910 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index: affected < 0.12.9; fixed in 0.12.9 ## Suggested inspection (read-only) - `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jvpf-xf32-2w4q (OSV record GHSA-jvpf-xf32-2w4q lists affected ranges: PyPI llama-index >=0 <0.12.9 (fixed)) - Verified: https://github.com/advisories/GHSA-jvpf-xf32-2w4q (GitHub-reviewed advisory GHSA-jvpf-xf32-2w4q lists affected ranges: PyPI llama-index >=0 <0.12.9) Commands are suggestions: review each one before running it.
Loading voting…