tar-fs Vulnerable to Link Following and Path Traversal via Extracting a Crafted tar File
CVE-2024-12905GHSA-pq67-2wwv-3xjx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar-fs 3.0.7, 2.1.2, 1.16.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm tar-fs
- Affected
- < 1.16.4>= 2.0.0, < 2.1.2>= 3.0.0, < 3.0.7
- Fixed in
- 2.1.2, 3.0.7, 1.16.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pq67-2wwv-3xjx lists affected ranges: npm tar-fs >=0 =2.0.0 =3.0.0 <3.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pq67-2wwv-3xjx lists affected ranges: npm tar-fs >=0 =2.0.0 =3.0.0 <3.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-12905: 2.30% estimated exploitation activity in the next 30 days; percentile 83.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An Improper Link Resolution Before File Access ("Link Following") and Improper Limitation of a Pathname to a Restricted Directory ("Path Traversal"). This vulnerability occurs when extracting a maliciously crafted tar file, which can result in unauthorized file writes or overwrites outside the intended extraction directory. The issue is associated with index.js in the tar-fs package. This issue affects tar-fs: from 0.0.0 before 1.16.4, from 2.0.0 before 2.1.2, from 3.0.0 before 3.0.7. PoC
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pq67-2wwv-3xjx
- Revision 1 · created ·
Published from osv record GHSA-pq67-2wwv-3xjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-12905 Advisory: tar-fs Vulnerable to Link Following and Path Traversal via Extracting a Crafted tar File IDs: CVE-2024-12905, GHSA-pq67-2wwv-3xjx Record: https://patchnext.com/advisories/cve-2024-12905 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tar-fs 3.0.7, 2.1.2, 1.16.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm tar-fs: affected < 1.16.4; >= 2.0.0, < 2.1.2; >= 3.0.0, < 3.0.7; fixed in 2.1.2, 3.0.7, 1.16.4 ## Suggested inspection (read-only) - `npm ls tar-fs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tar-fs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pq67-2wwv-3xjx (OSV record GHSA-pq67-2wwv-3xjx lists affected ranges: npm tar-fs >=0 =2.0.0 =3.0.0 <3.0.7 (fixed)) - Verified: https://github.com/advisories/GHSA-pq67-2wwv-3xjx (GitHub-reviewed advisory GHSA-pq67-2wwv-3xjx lists affected ranges: npm tar-fs >=0 =2.0.0 =3.0.0 <3.0.7) Commands are suggestions: review each one before running it.
Loading voting…