Skip to content

← Actionable
High, CVSS 8.6amended

Amazon Redshift Python Connector vulnerable to SQL Injection

CVE-2024-12745GHSA-8gc2-vq6m-rwjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (redshift-connector 2.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-12745: 0.53% estimated exploitation activity in the next 30 days; percentile 44.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A SQL injection in the Amazon Redshift Python Connector in version 2.1.4 allows a user to gain escalated privileges via schema injection in the getschemas, gettables, or getcolumns Metadata APIs. Users should upgrade to the driver version 2.1.5 or revert to driver version 2.1.3. Impact A SQL injection is possible in the Amazon Redshift Python Connector, version 2.1.4, when leveraging metadata APIs to retrieve information about database schemas, tables, or columns. Impacted versions: Amazon Redshift Python Connector version 2.1.4. Patches The issue described above has been addressed in the Amazon Redshift Python Connector, version 2.1.5. The patch implemented in this version ensures that every metadata command input is sent to the Redshift server as part of a parameterized query, using either QUOTEIDENT(string) or QUOTELITERAL(string). After processing all the inputs into quoted identifiers or literals, the metadata command is composed using these inputs and then executed on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8gc2-vq6m-rwjw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8gc2-vq6m-rwjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-12745

Advisory: Amazon Redshift Python Connector vulnerable to SQL Injection
IDs: CVE-2024-12745, GHSA-8gc2-vq6m-rwjw
Record: https://patchnext.com/advisories/cve-2024-12745 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: redshift-connector 2.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI redshift-connector: affected >= 2.1.4, <= 2.1.4; fixed in 2.1.5

## Suggested inspection (read-only)
- `python -m pip show redshift-connector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on redshift-connector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8gc2-vq6m-rwjw (OSV record GHSA-8gc2-vq6m-rwjw lists affected ranges: PyPI redshift-connector >=2.1.4 <2.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-8gc2-vq6m-rwjw (GitHub-reviewed advisory GHSA-8gc2-vq6m-rwjw lists affected ranges: PyPI redshift-connector >=2.1.4 <=2.1.4)

Commands are suggestions: review each one before running it.

Loading voting…