Skip to content

← Actionable
Medium, CVSS 4.2

WildFly Elytron OpenID Connect Client ExtensionOIDC authorization code injection attack

CVE-2024-12369GHSA-5565-3c98-g6jc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.security:wildfly-elytron 2.6.2.Final, 2.2.9.Final; org.wildfly.security:wildfly-elytron-http-oidc 2.6.2.Final, 2.2.9.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5565-3c98-g6jc lists affected ranges: Maven org.wildfly.security:wildfly-elytron >=1.17.0.Final =2.3.0.Final =1.17.0.Final =2.3.0.Final <2.6.2.Final

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-12369: 0.24% estimated exploitation activity in the next 30 days; percentile 15.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability was found in OIDC-Client. When using the elytron-oidc-client subsystem with WildFly, authorization code injection attacks can occur, allowing an attacker to inject a stolen authorization code into the attacker's own session with the client with a victim's identity. This is usually done with a Man-in-the-Middle (MitM) or phishing attack. Patches 2.2.9.Final 2.6.2.Final Workarounds Currently, no mitigation is currently available for this vulnerability. References https://nvd.nist.gov/vuln/detail/CVE-2024-12369 https://access.redhat.com/security/cve/CVE-2024-12369 https://bugzilla.redhat.com/showbug.cgi?id=2331178 https://issues.redhat.com/browse/ELY-2887

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5565-3c98-g6jc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-12369

Advisory: WildFly Elytron OpenID Connect Client ExtensionOIDC authorization code injection attack
IDs: CVE-2024-12369, GHSA-5565-3c98-g6jc
Record: https://patchnext.com/advisories/cve-2024-12369 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.wildfly.security:wildfly-elytron 2.6.2.Final, 2.2.9.Final; org.wildfly.security:wildfly-elytron-http-oidc 2.6.2.Final, 2.2.9.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.wildfly.security:wildfly-elytron: affected >= 1.17.0.Final, < 2.2.9.Final; >= 2.3.0.Final, < 2.6.2.Final; fixed in 2.6.2.Final, 2.2.9.Final
- Maven org.wildfly.security:wildfly-elytron-http-oidc: affected >= 1.17.0.Final, < 2.2.9.Final; >= 2.3.0.Final, < 2.6.2.Final; fixed in 2.6.2.Final, 2.2.9.Final

## Suggested inspection (read-only)
- Maven org.wildfly.security:wildfly-elytron: check the installed version with your package manager.
- Maven org.wildfly.security:wildfly-elytron-http-oidc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.wildfly.security:wildfly-elytron, org.wildfly.security:wildfly-elytron-http-oidc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5565-3c98-g6jc (GitHub-reviewed advisory GHSA-5565-3c98-g6jc lists affected ranges: Maven org.wildfly.security:wildfly-elytron >=1.17.0.Final =2.3.0.Final =1.17.0.Final =2.3.0.Final <2.6.2.Final)

Commands are suggestions: review each one before running it.

Loading voting…