LlamaIndex Retrievers Integration: DuckDBRetriever SQL Injection
CVE-2024-11958GHSA-339r-cjv9-x78g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index-retrievers-duckdb-retriever 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index-retrievers-duckdb-retriever
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-339r-cjv9-x78g lists affected ranges: PyPI llama-index-retrievers-duckdb-retriever >=0 <0.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-339r-cjv9-x78g lists affected ranges: PyPI llama-index-retrievers-duckdb-retriever >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-11958: 1.44% estimated exploitation activity in the next 30 days; percentile 73.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A SQL injection vulnerability exists in the duckdbretriever component of the run-llama/llamaindex repository, specifically in llama-index-retrievers-duckdb-retriever prior to v0.4.0. The vulnerability arises from the construction of SQL queries without using prepared statements, allowing an attacker to inject arbitrary SQL code. This can lead to remote code execution (RCE) by installing the shellfs extension and executing malicious commands.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-339r-cjv9-x78g
- Revision 1 · created ·
Published from osv record GHSA-339r-cjv9-x78g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-11958 Advisory: LlamaIndex Retrievers Integration: DuckDBRetriever SQL Injection IDs: CVE-2024-11958, GHSA-339r-cjv9-x78g Record: https://patchnext.com/advisories/cve-2024-11958 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index-retrievers-duckdb-retriever 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index-retrievers-duckdb-retriever: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - `python -m pip show llama-index-retrievers-duckdb-retriever`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index-retrievers-duckdb-retriever. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-339r-cjv9-x78g (OSV record GHSA-339r-cjv9-x78g lists affected ranges: PyPI llama-index-retrievers-duckdb-retriever >=0 <0.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-339r-cjv9-x78g (GitHub-reviewed advisory GHSA-339r-cjv9-x78g lists affected ranges: PyPI llama-index-retrievers-duckdb-retriever >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…