Skip to content

← Actionable
High, CVSS 8.1

Pimcore Authenticated Stored Cross-Site Scripting (XSS) Via Search Document

CVE-2024-11954GHSA-xr3m-6gq6-22cg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 11.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2024-11954: 1.09% estimated exploitation activity in the next 30 days; percentile 65.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Stored Cross-Site Scripting (XSS) vulnerability in PIMCORE allows remote attackers to inject arbitrary web script or HTML via the PDF upload functionality. This can result in the execution of malicious scripts in the context of the user's browser when the PDF is viewed, leading to potential session hijacking, defacement of web pages, or unauthorized access to sensitive information. Details The vulnerability is present in the PDF upload functionality of the PIM Core Upload module. When a user uploads a PDF file, the application fails to properly sanitize the content, allowing embedded scripts to be executed when the PDF is viewed. The affected code is located in the file handling and rendering logic of the PDF upload feature. PoC 1. Log in as Administrator 2. Hover to Assets 3. Right click and click "Add Asset(s) upload files 4. Upload malicious pdf 5. Click on search and select document 6. copy the path and open to a new tab https://demo.pimcore.fun/admin/Sample C 7. XSS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xr3m-6gq6-22cg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-11954

Advisory: Pimcore Authenticated Stored Cross-Site Scripting (XSS) Via Search Document
IDs: CVE-2024-11954, GHSA-xr3m-6gq6-22cg
Record: https://patchnext.com/advisories/cve-2024-11954 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 11.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected >= 11.4.2, < 11.5.3; fixed in 11.5.3

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xr3m-6gq6-22cg (GitHub-reviewed advisory GHSA-xr3m-6gq6-22cg lists affected ranges: Packagist pimcore/pimcore >=11.4.2 <11.5.3)

Commands are suggestions: review each one before running it.

Loading voting…