Skip to content

← Actionable
Medium, CVSS 5.9

Drupal core vulnerable to improper error handling

CVE-2024-11942GHSA-52jr-x6h6-xj6g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 10.2.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 10.0.0, < 10.2.10
    Fixed in
    10.2.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2024-11942: 0.39% estimated exploitation activity in the next 30 days; percentile 32.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Under certain uncommon site configurations, a bug in the CKEditor 5 module can cause some image uploads to move the entire webroot to a different location on the file system. This could be exploited by a malicious user to take down a site. The issue is mitigated by the fact that several non-default site configurations must exist simultaneously for this to occur.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-52jr-x6h6-xj6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-11942

Advisory: Drupal core vulnerable to improper error handling
IDs: CVE-2024-11942, GHSA-52jr-x6h6-xj6g
Record: https://patchnext.com/advisories/cve-2024-11942 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 10.2.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 10.0.0, < 10.2.10; fixed in 10.2.10

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-52jr-x6h6-xj6g (GitHub-reviewed advisory GHSA-52jr-x6h6-xj6g lists affected ranges: Packagist drupal/core >=10.0.0 <10.2.10)

Commands are suggestions: review each one before running it.

Loading voting…