Skip to content

← Actionable
Medium, CVSS 5.4amended

Cross-site Scripting (XSS) in serialize-javascript

CVE-2024-11831GHSA-76p7-773f-r4q5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (serialize-javascript 6.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-11831: 1.12% estimated exploitation activity in the next 30 days; percentile 66.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in npm-serialize-javascript. The vulnerability occurs because the serialize-javascript module does not properly sanitize certain inputs, such as regex or other JavaScript object types, allowing an attacker to inject malicious code. This code could be executed when deserialized by a web browser, causing Cross-site scripting (XSS) attacks. This issue is critical in environments where serialized data is sent to web clients, potentially compromising the security of the website or web application using this package.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-76p7-773f-r4q5

  2. Revision 1 · created ·

    Published from osv record GHSA-76p7-773f-r4q5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-11831

Advisory: Cross-site Scripting (XSS) in serialize-javascript
IDs: CVE-2024-11831, GHSA-76p7-773f-r4q5
Record: https://patchnext.com/advisories/cve-2024-11831 (revision 2, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: serialize-javascript 6.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm serialize-javascript: affected >= 6.0.0, < 6.0.2; fixed in 6.0.2

## Suggested inspection (read-only)
- `npm ls serialize-javascript --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on serialize-javascript.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-76p7-773f-r4q5 (OSV record GHSA-76p7-773f-r4q5 lists affected ranges: npm serialize-javascript >=6.0.0 <6.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-76p7-773f-r4q5 (GitHub-reviewed advisory GHSA-76p7-773f-r4q5 lists affected ranges: npm serialize-javascript >=6.0.0 <6.0.2)

Commands are suggestions: review each one before running it.

Loading voting…