Skip to content

← Actionable
Critical, CVSS 9.3

Central Dogma Authentication Bypass Vulnerability via Session Leakage

CVE-2024-1143GHSA-34q3-p352-c7q8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.linecorp.centraldogma:centraldogma-server 0.64.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2024-1143: 0.49% estimated exploitation activity in the next 30 days; percentile 42.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Overview A vulnerability has been identified in Central Dogma versions prior to 0.64.1, allowing for the leakage of user sessions and subsequent authentication bypass. The issue stems from a Cross-Site Scripting (XSS) attack vector that targets the RelayState of Security Assertion Markup Language (SAML). Impact Successful exploitation of this vulnerability enables malicious actors to leak user sessions, leading to the compromise of authentication mechanisms. This, in turn, can facilitate unauthorized access to sensitive resources. Patches This vulnerability is addressed and resolved in Central Dogma version 0.64.1 Users are strongly encouraged to upgrade to this version or later to mitigate the risk associated with the authentication bypass. Workarounds No viable workarounds are currently available for this vulnerability. It is recommended to apply the provided patch promptly. References - OASIS SAML v2.0 Errata 05 - OWASP XSS Prevention Cheat Sheet

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-34q3-p352-c7q8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-1143

Advisory: Central Dogma Authentication Bypass Vulnerability via Session Leakage
IDs: CVE-2024-1143, GHSA-34q3-p352-c7q8
Record: https://patchnext.com/advisories/cve-2024-1143 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.linecorp.centraldogma:centraldogma-server 0.64.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.linecorp.centraldogma:centraldogma-server: affected < 0.64.1; fixed in 0.64.1

## Suggested inspection (read-only)
- Maven com.linecorp.centraldogma:centraldogma-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.linecorp.centraldogma:centraldogma-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-34q3-p352-c7q8 (GitHub-reviewed advisory GHSA-34q3-p352-c7q8 lists affected ranges: Maven com.linecorp.centraldogma:centraldogma-server >=0 <0.64.1)

Commands are suggestions: review each one before running it.

Loading voting…