Request smuggling leading to endpoint restriction bypass in Gunicorn
CVE-2024-1135GHSA-w3h3-4rj7-4ph4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gunicorn 22.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gunicorn
- Affected
- < 22.0.0
- Fixed in
- 22.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w3h3-4rj7-4ph4 lists affected ranges: PyPI gunicorn >=0 <22.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3h3-4rj7-4ph4 lists affected ranges: PyPI gunicorn >=0 <22.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2024-1135: 3.00% estimated exploitation activity in the next 30 days; percentile 87.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Gunicorn fails to properly validate Transfer-Encoding headers, leading to HTTP Request Smuggling (HRS) vulnerabilities. By crafting requests with conflicting Transfer-Encoding headers, attackers can bypass security restrictions and access restricted endpoints. This issue is due to Gunicorn's handling of Transfer-Encoding headers, where it incorrectly processes requests with multiple, conflicting Transfer-Encoding headers, treating them as chunked regardless of the final encoding specified. This vulnerability has been shown to allow access to endpoints restricted by gunicorn. This issue has been addressed in version 22.0.0. To be affected users must have a network path which does not filter out invalid requests. These users are advised to block access to restricted endpoints via a firewall or other mechanism if they are unable to update.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w3h3-4rj7-4ph4
- Revision 1 · created ·
Published from osv record GHSA-w3h3-4rj7-4ph4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-1135 Advisory: Request smuggling leading to endpoint restriction bypass in Gunicorn IDs: CVE-2024-1135, GHSA-w3h3-4rj7-4ph4 Record: https://patchnext.com/advisories/cve-2024-1135 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gunicorn 22.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gunicorn: affected < 22.0.0; fixed in 22.0.0 ## Suggested inspection (read-only) - `python -m pip show gunicorn`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gunicorn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w3h3-4rj7-4ph4 (OSV record GHSA-w3h3-4rj7-4ph4 lists affected ranges: PyPI gunicorn >=0 <22.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w3h3-4rj7-4ph4 (GitHub-reviewed advisory GHSA-w3h3-4rj7-4ph4 lists affected ranges: PyPI gunicorn >=0 <22.0.0) Commands are suggestions: review each one before running it.
Loading voting…