django CMS Cross-Site Scripting (XSS)
CVE-2024-11319GHSA-gv5h-5655-h4mv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (django-cms 4.1.4, 3.11.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI django-cms
- Affected
- >= 3.11.7, < 3.11.9>= 4.1.2, < 4.1.4
- Fixed in
- 4.1.4, 3.11.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gv5h-5655-h4mv lists affected ranges: PyPI django-cms >=3.11.7 =4.1.2 <4.1.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gv5h-5655-h4mv lists affected ranges: PyPI django-cms >=3.11.7 =4.1.2 <4.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-11319: 0.54% estimated exploitation activity in the next 30 days; percentile 45.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in django CMS Association django-cms allows Cross-Site Scripting (XSS).This issue affects django-cms: 3.11.7, 3.11.8, 4.1.2, 4.1.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gv5h-5655-h4mv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-gv5h-5655-h4mv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-11319 Advisory: django CMS Cross-Site Scripting (XSS) IDs: CVE-2024-11319, GHSA-gv5h-5655-h4mv Record: https://patchnext.com/advisories/cve-2024-11319 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: django-cms 4.1.4, 3.11.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI django-cms: affected >= 3.11.7, < 3.11.9; >= 4.1.2, < 4.1.4; fixed in 4.1.4, 3.11.9 ## Suggested inspection (read-only) - `python -m pip show django-cms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on django-cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gv5h-5655-h4mv (OSV record GHSA-gv5h-5655-h4mv lists affected ranges: PyPI django-cms >=3.11.7 =4.1.2 <4.1.4 (fixed)) - Verified: https://github.com/advisories/GHSA-gv5h-5655-h4mv (GitHub-reviewed advisory GHSA-gv5h-5655-h4mv lists affected ranges: PyPI django-cms >=3.11.7 =4.1.2 <4.1.4) Commands are suggestions: review each one before running it.
Loading voting…