Firebase JavaScript SDK allows attackers to manipulate the "_authTokenSyncURL" to point to their own server
CVE-2024-11023GHSA-3wf4-68gx-mph8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (firebase 10.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm firebase
- Affected
- < 10.9.0
- Fixed in
- 10.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3wf4-68gx-mph8 lists affected ranges: npm firebase >=0 <10.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3wf4-68gx-mph8 lists affected ranges: npm firebase >=0 <10.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:L/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2024-11023: 0.13% estimated exploitation activity in the next 30 days; percentile 2.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Firebase JavaScript SDK utilizes a "FIREBASEDEFAULTS" cookie to store configuration data, including an "authTokenSyncURL" field used for session synchronization. If this cookie field is preset via an attacker by any other method, the attacker can manipulate the "authTokenSyncURL" to point to their own server and it would allow am actor to capture user session data transmitted by the SDK. We recommend upgrading Firebase JS SDK at least to 10.9.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3wf4-68gx-mph8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3wf4-68gx-mph8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-11023 Advisory: Firebase JavaScript SDK allows attackers to manipulate the "_authTokenSyncURL" to point to their own server IDs: CVE-2024-11023, GHSA-3wf4-68gx-mph8 Record: https://patchnext.com/advisories/cve-2024-11023 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: firebase 10.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm firebase: affected < 10.9.0; fixed in 10.9.0 ## Suggested inspection (read-only) - `npm ls firebase --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on firebase. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3wf4-68gx-mph8 (OSV record GHSA-3wf4-68gx-mph8 lists affected ranges: npm firebase >=0 <10.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-3wf4-68gx-mph8 (GitHub-reviewed advisory GHSA-3wf4-68gx-mph8 lists affected ranges: npm firebase >=0 <10.9.0) Commands are suggestions: review each one before running it.
Loading voting…