DB-GPT Absolute Path Traversal in knowledge/{space_name}/document/upload
CVE-2024-10833GHSA-j9g7-mqhh-9hxf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbgpt 0.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dbgpt
- Affected
- < 0.6.2
- Fixed in
- 0.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j9g7-mqhh-9hxf lists affected ranges: PyPI dbgpt >=0 <0.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j9g7-mqhh-9hxf lists affected ranges: PyPI dbgpt >=0 <0.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2024-10833: 0.84% estimated exploitation activity in the next 30 days; percentile 57.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
eosphoros-ai/db-gpt version 0.6.0 is vulnerable to an arbitrary file write through the knowledge API. The endpoint for uploading files as 'knowledge' is susceptible to absolute path traversal, allowing attackers to write files to arbitrary locations on the target server. This vulnerability arises because the 'doc_file.filename' parameter is user-controllable, enabling the construction of absolute paths.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-j9g7-mqhh-9hxf
- Revision 3 · amended ·
Amended from ghsa record GHSA-j9g7-mqhh-9hxf
- Revision 2 · amended ·
Amended from ghsa record GHSA-j9g7-mqhh-9hxf
- Revision 1 · created ·
Published from osv record GHSA-j9g7-mqhh-9hxf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10833
Advisory: DB-GPT Absolute Path Traversal in knowledge/{space_name}/document/upload
IDs: CVE-2024-10833, GHSA-j9g7-mqhh-9hxf
Record: https://patchnext.com/advisories/cve-2024-10833 (revision 4, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dbgpt 0.6.2. A vendor fix does not mean a deployment is fixed.
## Affected components
- PyPI dbgpt: affected < 0.6.2; fixed in 0.6.2
## Suggested inspection (read-only)
- `python -m pip show dbgpt`: prints the installed version. Run with the environment that serves production active.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dbgpt.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j9g7-mqhh-9hxf (OSV record GHSA-j9g7-mqhh-9hxf lists affected ranges: PyPI dbgpt >=0 <0.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-j9g7-mqhh-9hxf (GitHub-reviewed advisory GHSA-j9g7-mqhh-9hxf lists affected ranges: PyPI dbgpt >=0 <0.6.2)
Commands are suggestions: review each one before running it.Loading voting…