H2O Deserialization of Untrusted Data Vulnerability
CVE-2024-10553GHSA-h7xg-cmpp-48hf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (h2o 3.46.0.6; ai.h2o:h2o-core 3.46.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI h2o
- Affected
- < 3.46.0.6
- Fixed in
- 3.46.0.6
Maven ai.h2o:h2o-core
- Affected
- < 3.46.0.6
- Fixed in
- 3.46.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h7xg-cmpp-48hf lists affected ranges: PyPI h2o >=0 =0 <3.46.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h7xg-cmpp-48hf lists affected ranges: PyPI h2o >=0 =0 <3.46.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-10553: 1.59% estimated exploitation activity in the next 30 days; percentile 75.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the h2oai/h2o-3 REST API versions 3.46.0.4 allows unauthenticated remote attackers to execute arbitrary code via deserialization of untrusted data. The vulnerability exists in the endpoints POST /99/ImportSQLTable and POST /3/SaveToHiveTable, where user-controlled JDBC URLs are passed to DriverManager.getConnection, leading to deserialization if a MySQL or PostgreSQL driver is available in the classpath. This issue is fixed in version 3.46.0.6.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-h7xg-cmpp-48hf
- Revision 3 · amended ·
Amended from ghsa record GHSA-h7xg-cmpp-48hf
- Revision 2 · amended ·
Amended from ghsa record GHSA-h7xg-cmpp-48hf
- Revision 1 · created ·
Published from osv record GHSA-h7xg-cmpp-48hf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10553 Advisory: H2O Deserialization of Untrusted Data Vulnerability IDs: CVE-2024-10553, GHSA-h7xg-cmpp-48hf Record: https://patchnext.com/advisories/cve-2024-10553 (revision 4, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: h2o 3.46.0.6; ai.h2o:h2o-core 3.46.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI h2o: affected < 3.46.0.6; fixed in 3.46.0.6 - Maven ai.h2o:h2o-core: affected < 3.46.0.6; fixed in 3.46.0.6 ## Suggested inspection (read-only) - `python -m pip show h2o`: prints the installed version. Run with the environment that serves production active. - Maven ai.h2o:h2o-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on h2o, ai.h2o:h2o-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h7xg-cmpp-48hf (OSV record GHSA-h7xg-cmpp-48hf lists affected ranges: PyPI h2o >=0 =0 <3.46.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-h7xg-cmpp-48hf (GitHub-reviewed advisory GHSA-h7xg-cmpp-48hf lists affected ranges: PyPI h2o >=0 =0 <3.46.0.6) Commands are suggestions: review each one before running it.
Loading voting…