Boundary vulnerable to session hijacking through TLS certificate tampering
CVE-2024-1052GHSA-vh73-q3rw-qx7w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/boundary 0.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hashicorp/boundary
- Affected
- >= 0.8.0, < 0.15.0
- Fixed in
- 0.15.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vh73-q3rw-qx7w lists affected ranges: Go github.com/hashicorp/boundary >=0.8.0 <0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-1052: 0.29% estimated exploitation activity in the next 30 days; percentile 22.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Boundary and Boundary Enterprise (“Boundary”) is vulnerable to session hijacking through TLS certificate tampering. An attacker with privileges to enumerate active or pending sessions, obtain a private key pertaining to a session, and obtain a valid trust on first use (TOFU) token may craft a TLS certificate to hijack an active session and gain access to the underlying service or application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vh73-q3rw-qx7w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-1052 Advisory: Boundary vulnerable to session hijacking through TLS certificate tampering IDs: CVE-2024-1052, GHSA-vh73-q3rw-qx7w Record: https://patchnext.com/advisories/cve-2024-1052 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/boundary 0.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/boundary: affected >= 0.8.0, < 0.15.0; fixed in 0.15.0 ## Suggested inspection (read-only) - Go github.com/hashicorp/boundary: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/boundary. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vh73-q3rw-qx7w (GitHub-reviewed advisory GHSA-vh73-q3rw-qx7w lists affected ranges: Go github.com/hashicorp/boundary >=0.8.0 <0.15.0) Commands are suggestions: review each one before running it.
Loading voting…