Kubernetes kubelet arbitrary command execution
CVE-2024-10220GHSA-27wf-5967-98gx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.30.3, 1.29.7, 1.28.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.28.12>= 1.29.0, < 1.29.7>= 1.30.0, < 1.30.3
- Fixed in
- 1.28.12, 1.30.3, 1.29.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27wf-5967-98gx lists affected ranges: Go k8s.io/kubernetes >=0 =1.29.0 =1.30.0 <1.30.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-10220: 3.03% estimated exploitation activity in the next 30 days; percentile 87.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Kubernetes kubelet component allows arbitrary command execution via specially crafted gitRepo volumes.This issue affects kubelet: through 1.28.11, from 1.29.0 through 1.29.6, from 1.30.0 through 1.30.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-27wf-5967-98gx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10220 Advisory: Kubernetes kubelet arbitrary command execution IDs: CVE-2024-10220, GHSA-27wf-5967-98gx Record: https://patchnext.com/advisories/cve-2024-10220 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.30.3, 1.29.7, 1.28.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/kubernetes: affected < 1.28.12; >= 1.29.0, < 1.29.7; >= 1.30.0, < 1.30.3; fixed in 1.28.12, 1.30.3, 1.29.7 ## Suggested inspection (read-only) - Go k8s.io/kubernetes: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27wf-5967-98gx (GitHub-reviewed advisory GHSA-27wf-5967-98gx lists affected ranges: Go k8s.io/kubernetes >=0 =1.29.0 =1.30.0 <1.30.3) Commands are suggestions: review each one before running it.
Loading voting…