LiteLLM Vulnerable to Denial of Service (DoS)
CVE-2024-10188GHSA-gw2q-qw9j-rgv7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.53.1.dev1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- < 1.53.1.dev1
- Fixed in
- 1.53.1.dev1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gw2q-qw9j-rgv7 lists affected ranges: PyPI litellm >=0 <1.53.1.dev1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gw2q-qw9j-rgv7 lists affected ranges: PyPI litellm >=0 <1.53.1.dev1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-10188: 0.57% estimated exploitation activity in the next 30 days; percentile 47.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literaleval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gw2q-qw9j-rgv7
- Revision 1 · created ·
Published from osv record GHSA-gw2q-qw9j-rgv7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10188 Advisory: LiteLLM Vulnerable to Denial of Service (DoS) IDs: CVE-2024-10188, GHSA-gw2q-qw9j-rgv7 Record: https://patchnext.com/advisories/cve-2024-10188 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.53.1.dev1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected < 1.53.1.dev1; fixed in 1.53.1.dev1 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gw2q-qw9j-rgv7 (OSV record GHSA-gw2q-qw9j-rgv7 lists affected ranges: PyPI litellm >=0 <1.53.1.dev1 (fixed)) - Verified: https://github.com/advisories/GHSA-gw2q-qw9j-rgv7 (GitHub-reviewed advisory GHSA-gw2q-qw9j-rgv7 lists affected ranges: PyPI litellm >=0 <1.53.1.dev1) Commands are suggestions: review each one before running it.
Loading voting…