Skip to content

← Actionable
Critical, CVSS 9.4amended

codechecker authentication method confusion vulnerability allows logging in as the built-in root user from an external service

CVE-2024-10082GHSA-fpm5-2wcj-vfr7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codechecker 6.24.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2024-10082: 0.48% estimated exploitation activity in the next 30 days; percentile 41.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authentication method confusion allows logging in as the built-in root user from an external service. The built-in root user is generated in a weak manner, cannot be disabled, and has universal access. Details Until CodeChecker version 6.24.1 there was an auto-generated super-user account that could not be disabled. The attacker needs to know only the username of the root user. This root user is unconditionally assigned superuser permissions. Which means that if any user via any service logs in with the root user's username, they will unconditionally have superuser permissions on the CodeChecker instance. The name of the user name can be found in root.user file in the CodeChecker configuration directory. You can check if you are impacted by checking the existence of this user in the external authentication services (e.g. LDAP, PAM etc.). Impact This vulnerability allows an attacker who can create an account on an enabled external authentication service, to log in as the root…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fpm5-2wcj-vfr7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fpm5-2wcj-vfr7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-10082

Advisory: codechecker authentication method confusion vulnerability allows logging in as the built-in root user from an external service
IDs: CVE-2024-10082, GHSA-fpm5-2wcj-vfr7
Record: https://patchnext.com/advisories/cve-2024-10082 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codechecker 6.24.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI codechecker: affected <= 6.24.1; fixed in 6.24.2

## Suggested inspection (read-only)
- `python -m pip show codechecker`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codechecker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fpm5-2wcj-vfr7 (OSV record GHSA-fpm5-2wcj-vfr7 lists affected ranges: PyPI codechecker >=0 <6.24.2 (fixed))
- Verified: https://github.com/advisories/GHSA-fpm5-2wcj-vfr7 (GitHub-reviewed advisory GHSA-fpm5-2wcj-vfr7 lists affected ranges: PyPI codechecker >=0 <=6.24.1)

Commands are suggestions: review each one before running it.

Loading voting…