codechecker vulnerable to authentication bypass when using specifically crafted URLs
CVE-2024-10081GHSA-f3f8-vx3w-hp5q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codechecker 6.24.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI codechecker
- Affected
- < 6.24.2
- Fixed in
- 6.24.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f3f8-vx3w-hp5q lists affected ranges: PyPI codechecker >=0 <6.24.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f3f8-vx3w-hp5q lists affected ranges: PyPI codechecker >=0 <6.24.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2024-10081: 39.92% estimated exploitation activity in the next 30 days; percentile 98.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Authentication bypass occurs when the API URL ends with Authentication, Configuration or ServerInfo. This bypass allows superuser access to all API endpoints other than Authentication. These endpoints include the ability to add, edit, and remove products, among others. Details All endpoints, apart from the /Authentication is affected by the vulnerability. The vulnerability allows unauthenticated users to access all API functionality. You can look for the following pattern in the logs to check if the vulnerabilty was exploited: Note that the url starts with v and contains a valid CodeChecker endpoint, but it ends in Authentication, Configuration or ServerInfo and it was made by an Anonymous user. Impact This authentication bypass allows querying, adding, changing, and deleting Products contained on the CodeChecker server, without authentication, by an anonymous user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f3f8-vx3w-hp5q
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f3f8-vx3w-hp5q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10081 Advisory: codechecker vulnerable to authentication bypass when using specifically crafted URLs IDs: CVE-2024-10081, GHSA-f3f8-vx3w-hp5q Record: https://patchnext.com/advisories/cve-2024-10081 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codechecker 6.24.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI codechecker: affected < 6.24.2; fixed in 6.24.2 ## Suggested inspection (read-only) - `python -m pip show codechecker`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codechecker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f3f8-vx3w-hp5q (OSV record GHSA-f3f8-vx3w-hp5q lists affected ranges: PyPI codechecker >=0 <6.24.2 (fixed)) - Verified: https://github.com/advisories/GHSA-f3f8-vx3w-hp5q (GitHub-reviewed advisory GHSA-f3f8-vx3w-hp5q lists affected ranges: PyPI codechecker >=0 <6.24.2) Commands are suggestions: review each one before running it.
Loading voting…