Hashicorp Consul Improper Neutralization of HTTP Headers for Scripting Syntax vulnerability
CVE-2024-10006GHSA-5c4w-8hhh-3c3h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/consul 1.20.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hashicorp/consul
- Affected
- >= 1.9.0, < 1.20.1
- Fixed in
- 1.20.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5c4w-8hhh-3c3h lists affected ranges: Go github.com/hashicorp/consul >=1.9.0 <1.20.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L · score source
- EPSS
- CVE-2024-10006: 0.47% estimated exploitation activity in the next 30 days; percentile 40.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was identified in Consul and Consul Enterprise ("Consul") such that using Headers in L7 traffic intentions could bypass HTTP header based access rules.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5c4w-8hhh-3c3h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10006 Advisory: Hashicorp Consul Improper Neutralization of HTTP Headers for Scripting Syntax vulnerability IDs: CVE-2024-10006, GHSA-5c4w-8hhh-3c3h Record: https://patchnext.com/advisories/cve-2024-10006 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/consul 1.20.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/consul: affected >= 1.9.0, < 1.20.1; fixed in 1.20.1 ## Suggested inspection (read-only) - Go github.com/hashicorp/consul: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/consul. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5c4w-8hhh-3c3h (GitHub-reviewed advisory GHSA-5c4w-8hhh-3c3h lists affected ranges: Go github.com/hashicorp/consul >=1.9.0 <1.20.1) Commands are suggestions: review each one before running it.
Loading voting…