Hashicorp Consul Path Traversal vulnerability
CVE-2024-10005GHSA-chgm-7r52-whjj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/consul 1.20.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hashicorp/consul
- Affected
- >= 1.9.0, < 1.20.1
- Fixed in
- 1.20.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-chgm-7r52-whjj lists affected ranges: Go github.com/hashicorp/consul >=1.9.0 <1.20.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-10005: 0.77% estimated exploitation activity in the next 30 days; percentile 55.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was identified in Consul and Consul Enterprise ("Consul") such that using URL paths in L7 traffic intentions could bypass HTTP request path-based access rules.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-chgm-7r52-whjj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-10005 Advisory: Hashicorp Consul Path Traversal vulnerability IDs: CVE-2024-10005, GHSA-chgm-7r52-whjj Record: https://patchnext.com/advisories/cve-2024-10005 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/consul 1.20.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/consul: affected >= 1.9.0, < 1.20.1; fixed in 1.20.1 ## Suggested inspection (read-only) - Go github.com/hashicorp/consul: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/consul. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-chgm-7r52-whjj (GitHub-reviewed advisory GHSA-chgm-7r52-whjj lists affected ranges: Go github.com/hashicorp/consul >=1.9.0 <1.20.1) Commands are suggestions: review each one before running it.
Loading voting…