Kubernetes Nil pointer dereference in KCM after v1 HPA patch request
CVE-2024-0793GHSA-h7wq-jj8r-qm7p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.27.0-alpha.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.27.0-alpha.1
- Fixed in
- 1.27.0-alpha.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h7wq-jj8r-qm7p lists affected ranges: Go k8s.io/kubernetes >=0 <1.27.0-alpha.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
- EPSS
- CVE-2024-0793: 0.59% estimated exploitation activity in the next 30 days; percentile 48.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in kube-controller-manager. This issue occurs when the initial application of a HPA config YAML lacking a .spec.behavior.scaleUp block causes a denial of service due to KCM pods going into restart churn.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h7wq-jj8r-qm7p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-0793 Advisory: Kubernetes Nil pointer dereference in KCM after v1 HPA patch request IDs: CVE-2024-0793, GHSA-h7wq-jj8r-qm7p Record: https://patchnext.com/advisories/cve-2024-0793 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.27.0-alpha.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/kubernetes: affected < 1.27.0-alpha.1; fixed in 1.27.0-alpha.1 ## Suggested inspection (read-only) - Go k8s.io/kubernetes: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h7wq-jj8r-qm7p (GitHub-reviewed advisory GHSA-h7wq-jj8r-qm7p lists affected ranges: Go k8s.io/kubernetes >=0 <1.27.0-alpha.1) Commands are suggestions: review each one before running it.
Loading voting…