Null pointer dereference in PKCS12 parsing
CVE-2024-0727GHSA-9v9h-cgj8-h64p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 42.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptography
- Affected
- < 42.0.2
- Fixed in
- 42.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9v9h-cgj8-h64p lists affected ranges: PyPI cryptography >=0 <42.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9v9h-cgj8-h64p lists affected ranges: PyPI cryptography >=0 <42.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-0727: 3.19% estimated exploitation activity in the next 30 days; percentile 88.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Issue summary: Processing a maliciously formatted PKCS12 file may lead OpenSSL to crash leading to a potential Denial of Service attack Impact summary: Applications loading files in the PKCS12 format from untrusted sources might terminate abruptly. A file in PKCS12 format can contain certificates and keys and may come from an untrusted source. The PKCS12 specification allows certain fields to be NULL, but OpenSSL does not correctly check for this case. This can lead to a NULL pointer dereference that results in OpenSSL crashing. If an application processes PKCS12 files from an untrusted source using the OpenSSL APIs then that application will be vulnerable to this issue. OpenSSL APIs that are vulnerable to this are: PKCS12parse(), PKCS12unpackp7data(), PKCS12unpackp7encdata(), PKCS12unpackauthsafes() and PKCS12newpass(). We have also fixed a similar issue in SMIMEwritePKCS7(). However since this function is related to writing data we do not consider it security significant. The FIPS…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9v9h-cgj8-h64p
- Revision 1 · created ·
Published from osv record GHSA-9v9h-cgj8-h64p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-0727 Advisory: Null pointer dereference in PKCS12 parsing IDs: CVE-2024-0727, GHSA-9v9h-cgj8-h64p Record: https://patchnext.com/advisories/cve-2024-0727 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptography 42.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptography: affected < 42.0.2; fixed in 42.0.2 ## Suggested inspection (read-only) - `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptography. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9v9h-cgj8-h64p (OSV record GHSA-9v9h-cgj8-h64p lists affected ranges: PyPI cryptography >=0 <42.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9v9h-cgj8-h64p (GitHub-reviewed advisory GHSA-9v9h-cgj8-h64p lists affected ranges: PyPI cryptography >=0 <42.0.2) Commands are suggestions: review each one before running it.
Loading voting…