Remote code execution in mlflow
CVE-2024-0520GHSA-5q6c-ffvg-xcm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 2.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mlflow
- Affected
- < 2.9.0
- Fixed in
- 2.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5q6c-ffvg-xcm9 lists affected ranges: PyPI mlflow >=0 <2.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5q6c-ffvg-xcm9 lists affected ranges: PyPI mlflow >=0 <2.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-0520: 2.40% estimated exploitation activity in the next 30 days; percentile 84.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in mlflow/mlflow version 8.2.1 allows for remote code execution due to improper neutralization of special elements used in an OS command ('Command Injection') within the mlflow.data.httpdatasetsource.py module. Specifically, when loading a dataset from a source URL with an HTTP scheme, the filename extracted from the Content-Disposition header or the URL path is used to generate the final file path without proper sanitization. This flaw enables an attacker to control the file path fully by utilizing path traversal or absolute path techniques, such as '../../tmp/poc.txt' or '/tmp/poc.txt', leading to arbitrary file write. Exploiting this vulnerability could allow a malicious user to execute commands on the vulnerable machine, potentially gaining access to data and model information. The issue is fixed in version 2.9.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5q6c-ffvg-xcm9
- Revision 1 · created ·
Published from osv record GHSA-5q6c-ffvg-xcm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-0520 Advisory: Remote code execution in mlflow IDs: CVE-2024-0520, GHSA-5q6c-ffvg-xcm9 Record: https://patchnext.com/advisories/cve-2024-0520 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mlflow 2.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mlflow: affected < 2.9.0; fixed in 2.9.0 ## Suggested inspection (read-only) - `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mlflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5q6c-ffvg-xcm9 (OSV record GHSA-5q6c-ffvg-xcm9 lists affected ranges: PyPI mlflow >=0 <2.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5q6c-ffvg-xcm9 (GitHub-reviewed advisory GHSA-5q6c-ffvg-xcm9 lists affected ranges: PyPI mlflow >=0 <2.9.0) Commands are suggestions: review each one before running it.
Loading voting…