langchain Server-Side Request Forgery vulnerability
CVE-2024-0243GHSA-h9j7-5xvc-qhg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-exa 0.1.0; langchain 0.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain-exa
- Affected
- < 0.1.0
- Fixed in
- 0.1.0
PyPI langchain
- Affected
- < 0.1.0
- Fixed in
- 0.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h9j7-5xvc-qhg5 lists affected ranges: PyPI langchain >=0 <0.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-235 lists affected ranges: PyPI langchain-exa >=0 <0.1.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9j7-5xvc-qhg5 lists affected ranges: PyPI langchain >=0 <0.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-0243: 0.52% estimated exploitation activity in the next 30 days; percentile 44.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
With the following crawler configuration: An attacker in control of the contents of https://example.com could place a malicious HTML file in there with links like "https://example.completely.different/myfile.html" and the crawler would proceed to download that file as well even though preventoutside=True. https://github.com/langchain-ai/langchain/blob/bf0b3cc0b5ade1fb95a5b1b6fa260e99064c2e22/libs/community/langchaincommunity/documentloaders/recursiveurlloader.py#L51-L51 Resolved in https://github.com/langchain-ai/langchain/pull/15559
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h9j7-5xvc-qhg5
- Revision 2 · amended ·
Amended from osv record PYSEC-2024-235
- Revision 1 · created ·
Published from osv record GHSA-h9j7-5xvc-qhg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-0243 Advisory: langchain Server-Side Request Forgery vulnerability IDs: CVE-2024-0243, GHSA-h9j7-5xvc-qhg5 Record: https://patchnext.com/advisories/cve-2024-0243 (revision 3, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain-exa 0.1.0; langchain 0.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain-exa: affected < 0.1.0; fixed in 0.1.0 - PyPI langchain: affected < 0.1.0; fixed in 0.1.0 ## Suggested inspection (read-only) - `python -m pip show langchain-exa`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langchain`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain-exa, langchain. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h9j7-5xvc-qhg5 (OSV record GHSA-h9j7-5xvc-qhg5 lists affected ranges: PyPI langchain >=0 <0.1.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2024-235 (OSV record PYSEC-2024-235 lists affected ranges: PyPI langchain-exa >=0 <0.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h9j7-5xvc-qhg5 (GitHub-reviewed advisory GHSA-h9j7-5xvc-qhg5 lists affected ranges: PyPI langchain >=0 <0.1.0) Commands are suggestions: review each one before running it.
Loading voting…