encoded_id-rails potential DOS vulnerability due to URIs with extremely long encoded IDs
CVE-2024-0241GHSA-3px7-jm2p-6h2c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (encoded_id-rails 1.0.0.beta2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems encoded_id-rails
- Affected
- < 1.0.0.beta2
- Fixed in
- 1.0.0.beta2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3px7-jm2p-6h2c lists affected ranges: RubyGems encoded_id-rails >=0 <1.0.0.beta2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-0241: 1.11% estimated exploitation activity in the next 30 days; percentile 66.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The length of URIs and the various parts (eg path segments, query parameters) is usually limited by the webserver processing the incoming request. In the case of Puma the defaults are : - path segment length: 8192 - Max URI length: 1024 12 - Max query length: 1024 10 See https://github.com/puma/puma/blob/master/docs/compileoptions.md If too long Puma raises: Puma caught this error: HTTP element REQUESTPATH is longer than the (8192) allowed length (was 12503) (Puma::HttpParserError) However due to the performance of hashids extremely long encoded IDs will consume a large amount of CPU and allocate a huge number of intermediate objects. For example: This causes the application to spend a huge amount of time decoding the ID and the allocation of 200MB of objects. Patches Upgrade to 1.0.0.beta2 This introduces a new option to limit the length of IDs that can be decoded. A future release will also improve the performance and hugely reduce allocations in the underlying hashids…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3px7-jm2p-6h2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-0241 Advisory: encoded_id-rails potential DOS vulnerability due to URIs with extremely long encoded IDs IDs: CVE-2024-0241, GHSA-3px7-jm2p-6h2c Record: https://patchnext.com/advisories/cve-2024-0241 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: encoded_id-rails 1.0.0.beta2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems encoded_id-rails: affected < 1.0.0.beta2; fixed in 1.0.0.beta2 ## Suggested inspection (read-only) - RubyGems encoded_id-rails: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on encoded_id-rails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3px7-jm2p-6h2c (GitHub-reviewed advisory GHSA-3px7-jm2p-6h2c lists affected ranges: RubyGems encoded_id-rails >=0 <1.0.0.beta2) Commands are suggestions: review each one before running it.
Loading voting…