Skip to content

← Actionable
Critical, CVSS 9.3amended

Arbitrary remote code execution within wrangler dev Workers sandbox

CVE-2023-7080GHSA-f8mp-x433-5wpf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wrangler 3.19.0, 2.20.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm wrangler

    Affected
    >= 3.0.0, < 3.19.0>= 2.0.0, < 2.20.2
    Fixed in
    2.20.2, 3.19.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2023-7080: 0.63% estimated exploitation activity in the next 30 days; percentile 50.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The V8 inspector intentionally allows arbitrary code execution within the Workers sandbox for debugging. wrangler dev would previously start an inspector server listening on all network interfaces. This would allow an attacker on the local network to connect to the inspector and run arbitrary code. Additionally, the inspector server did not validate Origin/Host headers, granting an attacker that can trick any user on the local network into opening a malicious website the ability to run code. If wrangler dev --remote was being used, an attacker could access production resources if they were bound to the worker. Patches This issue was fixed in wrangler@3.19.0 and wrangler@2.20.2. Whilst wrangler dev's inspector server listens on local interfaces by default as of wrangler@3.16.0, an SSRF vulnerability in miniflare allowed access from the local network until wrangler@3.18.0. wrangler@3.19.0 and wrangler@2.20.2 introduced validation for the Origin/Host headers. Workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f8mp-x433-5wpf

  2. Revision 1 · created ·

    Published from osv record GHSA-f8mp-x433-5wpf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-7080

Advisory: Arbitrary remote code execution within `wrangler dev` Workers sandbox
IDs: CVE-2023-7080, GHSA-f8mp-x433-5wpf
Record: https://patchnext.com/advisories/cve-2023-7080 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wrangler 3.19.0, 2.20.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm wrangler: affected >= 3.0.0, < 3.19.0; >= 2.0.0, < 2.20.2; fixed in 2.20.2, 3.19.0

## Suggested inspection (read-only)
- `npm ls wrangler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wrangler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f8mp-x433-5wpf (OSV record GHSA-f8mp-x433-5wpf lists affected ranges: npm wrangler >=3.0.0 =2.0.0 <2.20.2 (fixed))
- Verified: https://github.com/advisories/GHSA-f8mp-x433-5wpf (GitHub-reviewed advisory GHSA-f8mp-x433-5wpf lists affected ranges: npm wrangler >=3.0.0 =2.0.0 <2.20.2)

Commands are suggestions: review each one before running it.

Loading voting…