Skip to content

← Actionable
Medium, CVSS 6.9amended

Arbitrary remote file read in Wrangler dev server

CVE-2023-7079GHSA-cfph-4qqh-w828

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wrangler 3.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm wrangler

    Affected
    >= 3.9.0, < 3.19.0
    Fixed in
    3.19.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.9 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2023-7079: 0.70% estimated exploitation activity in the next 30 days; percentile 53.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Sending specially crafted HTTP requests and inspector messages to Wrangler's dev server could result in any file on the user's computer being accessible over the local network. An attacker that could trick any user on the local network into opening a malicious website could also read any file. Patches This issue was fixed in wrangler@3.19.0. Wrangler will now only serve files that are part of your bundle, or referenced by your bundle's source maps. Workarounds Configure Wrangler to listen on local interfaces instead with wrangler dev --ip 127.0.0.1. This is the default as of wrangler@3.16.0, and removes the local network as an attack vector, but does not prevent an attack from visiting a malicious website. References - https://github.com/cloudflare/workers-sdk/pull/4532 - https://github.com/cloudflare/workers-sdk/pull/4535

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cfph-4qqh-w828

  2. Revision 1 · created ·

    Published from osv record GHSA-cfph-4qqh-w828

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-7079

Advisory: Arbitrary remote file read in Wrangler dev server
IDs: CVE-2023-7079, GHSA-cfph-4qqh-w828
Record: https://patchnext.com/advisories/cve-2023-7079 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wrangler 3.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm wrangler: affected >= 3.9.0, < 3.19.0; fixed in 3.19.0

## Suggested inspection (read-only)
- `npm ls wrangler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wrangler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cfph-4qqh-w828 (OSV record GHSA-cfph-4qqh-w828 lists affected ranges: npm wrangler >=3.9.0 <3.19.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cfph-4qqh-w828 (GitHub-reviewed advisory GHSA-cfph-4qqh-w828 lists affected ranges: npm wrangler >=3.9.0 <3.19.0)

Commands are suggestions: review each one before running it.

Loading voting…