Miniflare vulnerable to Server-Side Request Forgery (SSRF)
CVE-2023-7078GHSA-fwvg-2739-22v7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (miniflare 3.20231030.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm miniflare
- Affected
- >= 3.20230821.0, < 3.20231030.2
- Fixed in
- 3.20231030.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fwvg-2739-22v7 lists affected ranges: npm miniflare >=3.20230821.0 <3.20231030.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwvg-2739-22v7 lists affected ranges: npm miniflare >=3.20230821.0 <3.20231030.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2023-7078: 0.55% estimated exploitation activity in the next 30 days; percentile 46.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Sending specially crafted HTTP requests to Miniflare's server could result in arbitrary HTTP and WebSocket requests being sent from the server. If Miniflare was configured to listen on external network interfaces (as was the default in wrangler until 3.19.0), an attacker on the local network could access other local servers. Patches The issue was fixed in miniflare@3.20231030.2. Workarounds Ensure Miniflare is configured to listen on just local interfaces. This is the default behaviour, but can also be configured with the host: "127.0.0.1" option. References - https://github.com/cloudflare/workers-sdk/pull/4532
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fwvg-2739-22v7
- Revision 1 · created ·
Published from osv record GHSA-fwvg-2739-22v7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-7078 Advisory: Miniflare vulnerable to Server-Side Request Forgery (SSRF) IDs: CVE-2023-7078, GHSA-fwvg-2739-22v7 Record: https://patchnext.com/advisories/cve-2023-7078 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: miniflare 3.20231030.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm miniflare: affected >= 3.20230821.0, < 3.20231030.2; fixed in 3.20231030.2 ## Suggested inspection (read-only) - `npm ls miniflare --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on miniflare. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fwvg-2739-22v7 (OSV record GHSA-fwvg-2739-22v7 lists affected ranges: npm miniflare >=3.20230821.0 <3.20231030.2 (fixed)) - Verified: https://github.com/advisories/GHSA-fwvg-2739-22v7 (GitHub-reviewed advisory GHSA-fwvg-2739-22v7 lists affected ranges: npm miniflare >=3.20230821.0 <3.20231030.2) Commands are suggestions: review each one before running it.
Loading voting…