@backstage/backend-app-api leaks GitLab access tokens
CVE-2023-6944GHSA-86rg-pf4c-5grg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/backend-app-api 0.5.9-next.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/backend-app-api
- Affected
- < 0.5.9-next.1
- Fixed in
- 0.5.9-next.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-86rg-pf4c-5grg lists affected ranges: npm @backstage/backend-app-api >=0 <0.5.9-next.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-86rg-pf4c-5grg lists affected ranges: npm @backstage/backend-app-api >=0 <0.5.9-next.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-6944: 0.56% estimated exploitation activity in the next 30 days; percentile 46.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in the Red Hat Developer Hub (RHDH). The catalog-import function leaks GitLab access tokens on the frontend when the base64 encoded GitLab token includes a newline at the end of the string. The sanitized error can display on the frontend, including the raw access token. Upon gaining access to this token and depending on permissions, an attacker could push malicious code to repositories, delete resources in Git, revoke or generate new keys, and sign code illegitimately.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-86rg-pf4c-5grg
- Revision 1 · created ·
Published from osv record GHSA-86rg-pf4c-5grg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6944 Advisory: @backstage/backend-app-api leaks GitLab access tokens IDs: CVE-2023-6944, GHSA-86rg-pf4c-5grg Record: https://patchnext.com/advisories/cve-2023-6944 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/backend-app-api 0.5.9-next.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/backend-app-api: affected < 0.5.9-next.1; fixed in 0.5.9-next.1 ## Suggested inspection (read-only) - `npm ls @backstage/backend-app-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/backend-app-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-86rg-pf4c-5grg (OSV record GHSA-86rg-pf4c-5grg lists affected ranges: npm @backstage/backend-app-api >=0 <0.5.9-next.1 (fixed)) - Verified: https://github.com/advisories/GHSA-86rg-pf4c-5grg (GitHub-reviewed advisory GHSA-86rg-pf4c-5grg lists affected ranges: npm @backstage/backend-app-api >=0 <0.5.9-next.1) Commands are suggestions: review each one before running it.
Loading voting…