Login by Auth0 plugin for WordPress vulnerable to Reflected Cross-Site Scripting
CVE-2023-6813GHSA-x6p7-44rh-m3rr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/wordpress 4.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/wordpress
- Affected
- <= 4.6.0
- Fixed in
- 4.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x6p7-44rh-m3rr lists affected ranges: Packagist auth0/wordpress >=0 <=4.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-6813: 0.36% estimated exploitation activity in the next 30 days; percentile 29.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Auth0 WordPress plugin allows site administrators to opt-in to allowing the use of a wle parameter, which can be passed to the WordPress login page by end users. When this parameter is supplied using an expected value (which is randomly generated by the plugin, by default), the end user can fallback to using WordPress' native authentication behavior. (This is generally intended as an emergency fallback for administrators to still be able to access their dashboard in the event something goes wrong.) In previous versions of the plugin, under specific conditions, this parameter could potentially accept an arbitrary string that would be improperly rendered, potentially allowing for a cross-site scripting (XSS) attack on the login page. Patches Please upgrade to v4.6.1 of the plugin to resolve the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x6p7-44rh-m3rr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6813 Advisory: Login by Auth0 plugin for WordPress vulnerable to Reflected Cross-Site Scripting IDs: CVE-2023-6813, GHSA-x6p7-44rh-m3rr Record: https://patchnext.com/advisories/cve-2023-6813 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/wordpress 4.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/wordpress: affected <= 4.6.0; fixed in 4.6.1 ## Suggested inspection (read-only) - Packagist auth0/wordpress: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/wordpress. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x6p7-44rh-m3rr (GitHub-reviewed advisory GHSA-x6p7-44rh-m3rr lists affected ranges: Packagist auth0/wordpress >=0 <=4.6.0) Commands are suggestions: review each one before running it.
Loading voting…