CRI-O's pods can break out of resource confinement on cgroupv2
CVE-2023-6476GHSA-p4rx-7wvg-fwrc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cri-o/cri-o 1.29.1, 1.28.3, 1.27.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.29.0, <= 1.29.0>= 1.28.0, < 1.28.3< 1.27.3
- Fixed in
- 1.27.3, 1.29.1, 1.28.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p4rx-7wvg-fwrc lists affected ranges: Go github.com/cri-o/cri-o >=1.29.0 =1.28.0 =0 <1.27.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-6476: 0.86% estimated exploitation activity in the next 30 days; percentile 58.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? All versions of CRI-O running on cgroupv2 nodes. Unchecked access to an experimental annotation allows a container to be unconfined. Back in 2021, support was added to support an experimental annotation that allows a user to request special resources in cgroupv2. It was supposed to be gated by an experimental annotation: io.kubernetes.cri-o.UnifiedCgroup, which was supposed to be filtered from the list of allowed annotations . However, there is a bug in this code which allows any user to specify this annotation, regardless of whether it's enabled on the node. The consequences of this are a pod can specify any amount of memory/cpu and get it, circumventing the kubernetes scheduler, and potentially be able to DOS a node. Patches Has the problem been patched? What versions should users upgrade to? 1.29.1, 1.28.3, 1.27.3 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? use cgroupv1…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p4rx-7wvg-fwrc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6476 Advisory: CRI-O's pods can break out of resource confinement on cgroupv2 IDs: CVE-2023-6476, GHSA-p4rx-7wvg-fwrc Record: https://patchnext.com/advisories/cve-2023-6476 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cri-o/cri-o 1.29.1, 1.28.3, 1.27.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cri-o/cri-o: affected >= 1.29.0, <= 1.29.0; >= 1.28.0, < 1.28.3; < 1.27.3; fixed in 1.27.3, 1.29.1, 1.28.3 ## Suggested inspection (read-only) - Go github.com/cri-o/cri-o: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cri-o/cri-o. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p4rx-7wvg-fwrc (GitHub-reviewed advisory GHSA-p4rx-7wvg-fwrc lists affected ranges: Go github.com/cri-o/cri-o >=1.29.0 =1.28.0 =0 <1.27.3) Commands are suggestions: review each one before running it.
Loading voting…