Mattermost Injection vulnerability
CVE-2023-6458GHSA-7664-hcp7-f497
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 9.0.3, 8.1.5; github.com/mattermost/mattermost-server/v6 7.8.14; github.com/mattermost/mattermost/server 9.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.1.5>= 9.0.0, < 9.0.3
- Fixed in
- 9.0.3, 8.1.5
Go github.com/mattermost/mattermost-server/v6
- Affected
- < 7.8.14
- Fixed in
- 7.8.14
Go github.com/mattermost/mattermost/server
- Affected
- >= 9.1.0, < 9.1.2
- Fixed in
- 9.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7664-hcp7-f497 lists affected ranges: Go github.com/mattermost/mattermost-server/v6 >=0 =0 =9.0.0 =9.1.0 <9.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:L
- EPSS
- CVE-2023-6458: 0.64% estimated exploitation activity in the next 30 days; percentile 50.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost webapp fails to validate route parameters in/<TEAMNAME/channels/<CHANNELNAME allowing an attacker to perform a client-side path traversal.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7664-hcp7-f497
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6458 Advisory: Mattermost Injection vulnerability IDs: CVE-2023-6458, GHSA-7664-hcp7-f497 Record: https://patchnext.com/advisories/cve-2023-6458 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 9.0.3, 8.1.5; github.com/mattermost/mattermost-server/v6 7.8.14; github.com/mattermost/mattermost/server 9.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.1.5; >= 9.0.0, < 9.0.3; fixed in 9.0.3, 8.1.5 - Go github.com/mattermost/mattermost-server/v6: affected < 7.8.14; fixed in 7.8.14 - Go github.com/mattermost/mattermost/server: affected >= 9.1.0, < 9.1.2; fixed in 9.1.2 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. - Go github.com/mattermost/mattermost/server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7664-hcp7-f497 (GitHub-reviewed advisory GHSA-7664-hcp7-f497 lists affected ranges: Go github.com/mattermost/mattermost-server/v6 >=0 =0 =9.0.0 =9.1.0 <9.1.2) Commands are suggestions: review each one before running it.
Loading voting…