Skip to content

← Actionable
Medium, CVSS 6.7amended

Privilege escalation for users that can access mock configuration

CVE-2023-6395GHSA-7j98-74jh-cjxh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (templated-dictionary 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.7 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-6395: 1.55% estimated exploitation activity in the next 30 days; percentile 75.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Mock software contains a vulnerability wherein an attacker could potentially exploit privilege escalation, enabling the execution of arbitrary code with root user privileges. This weakness stems from the absence of proper sandboxing during the expansion and execution of Jinja2 templates, which may be included in certain configuration parameters. While the Mock documentation advises treating users added to the mock group as privileged, certain build systems invoking mock on behalf of users might inadvertently permit less privileged users to define configuration tags. These tags could then be passed as parameters to mock during execution, potentially leading to the utilization of Jinja2 templates for remote privilege escalation and the execution of arbitrary code as the root user on the build server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7j98-74jh-cjxh

  2. Revision 1 · created ·

    Published from osv record GHSA-7j98-74jh-cjxh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-6395

Advisory: Privilege escalation for users that can access mock configuration
IDs: CVE-2023-6395, GHSA-7j98-74jh-cjxh
Record: https://patchnext.com/advisories/cve-2023-6395 (revision 2, source checked 26 Oct 2026, 13:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: templated-dictionary 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI templated-dictionary: affected < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- `python -m pip show templated-dictionary`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on templated-dictionary.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7j98-74jh-cjxh (OSV record GHSA-7j98-74jh-cjxh lists affected ranges: PyPI templated-dictionary >=0 <1.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7j98-74jh-cjxh (GitHub-reviewed advisory GHSA-7j98-74jh-cjxh lists affected ranges: PyPI templated-dictionary >=0 <1.4.1)

Commands are suggestions: review each one before running it.

Loading voting…