Quarkus Cache Runtime exposes sensitive information to an unauthorized actor
CVE-2023-6393GHSA-xfv5-jqgp-vqhj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.quarkus:quarkus-cache 3.5.2, 3.2.9.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.quarkus:quarkus-cache
- Affected
- >= 3.3.0.CR1, < 3.5.2>= 3.2.0.CR1, < 3.2.9.Final
- Fixed in
- 3.5.2, 3.2.9.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xfv5-jqgp-vqhj lists affected ranges: Maven io.quarkus:quarkus-cache >=3.3.0.CR1 =3.2.0.CR1 <3.2.9.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-6393: 0.64% estimated exploitation activity in the next 30 days; percentile 50.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in the Quarkus Cache Runtime. When request processing utilizes a Uni cached using @CacheResult and the cached Uni reuses the initial "completion" context, the processing switches to the cached Uni instead of the request context. This is a problem if the cached Uni context contains sensitive information, and could allow a malicious user to benefit from a POST request returning the response that is meant for another user, gaining access to sensitive data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xfv5-jqgp-vqhj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6393 Advisory: Quarkus Cache Runtime exposes sensitive information to an unauthorized actor IDs: CVE-2023-6393, GHSA-xfv5-jqgp-vqhj Record: https://patchnext.com/advisories/cve-2023-6393 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.quarkus:quarkus-cache 3.5.2, 3.2.9.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.quarkus:quarkus-cache: affected >= 3.3.0.CR1, < 3.5.2; >= 3.2.0.CR1, < 3.2.9.Final; fixed in 3.5.2, 3.2.9.Final ## Suggested inspection (read-only) - Maven io.quarkus:quarkus-cache: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.quarkus:quarkus-cache. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xfv5-jqgp-vqhj (GitHub-reviewed advisory GHSA-xfv5-jqgp-vqhj lists affected ranges: Maven io.quarkus:quarkus-cache >=3.3.0.CR1 =3.2.0.CR1 <3.2.9.Final) Commands are suggestions: review each one before running it.
Loading voting…