Candid infinite decoding loop through specially crafted payload
CVE-2023-6245GHSA-7787-p7x6-fq3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (candid 0.9.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io candid
- Affected
- >= 0.9.0, < 0.9.10
- Fixed in
- 0.9.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7787-p7x6-fq3j lists affected ranges: crates.io candid >=0.9.0 <0.9.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-6245: 1.21% estimated exploitation activity in the next 30 days; percentile 68.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Candid library causes a Denial of Service while parsing a specially crafted payload with empty data type. For example, if the payload is record { ; empty } and the canister interface expects record { } then the rust candid decoder treats empty as an extra field required by the type. The problem with type empty is that the candid rust library wrongly categorizes empty as a recoverable error when skipping the field and thus causing an infinite decoding loop. Canisters using affected versions of candid are exposed to denial of service by causing the decoding to run indefinitely until the canister traps due to reaching maximum instruction limit per execution round. Repeated exposure to the payload will result in degraded performance of the canister. For asset canister users, dfx versions = 0.14.4 to <= 0.15.2-beta.0 ships asset canister with an affected version of candid. Unaffected - Rust canisters using candid < 0.9.0 or = 0.9.10 - Rust canister interfaces of type other than…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7787-p7x6-fq3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6245 Advisory: Candid infinite decoding loop through specially crafted payload IDs: CVE-2023-6245, GHSA-7787-p7x6-fq3j Record: https://patchnext.com/advisories/cve-2023-6245 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: candid 0.9.10. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io candid: affected >= 0.9.0, < 0.9.10; fixed in 0.9.10 ## Suggested inspection (read-only) - crates.io candid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on candid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7787-p7x6-fq3j (GitHub-reviewed advisory GHSA-7787-p7x6-fq3j lists affected ranges: crates.io candid >=0.9.0 <0.9.10) Commands are suggestions: review each one before running it.
Loading voting…