Skip to content

← Actionable
High, CVSS 7.3

WildFly Elytron: OIDC app attempting to access the second tenant, the user should be prompted to log

CVE-2023-6236GHSA-jpmx-996v-48fm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.security:wildfly-elytron-http-oidc 2.2.5.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-6236: 0.33% estimated exploitation activity in the next 30 days; percentile 25.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in JBoss EAP. When an OIDC app that serves multiple tenants attempts to access the second tenant, it should prompt the user to log in again since the second tenant is secured with a different OIDC configuration. The underlying issue is in OidcSessionTokenStore when determining if a cached token should be used or not. This logic needs to be updated to take into account the new "provider-url" option in addition to the "realm" option.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jpmx-996v-48fm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-6236

Advisory: WildFly Elytron: OIDC app attempting to access the second tenant, the user should be prompted to log
IDs: CVE-2023-6236, GHSA-jpmx-996v-48fm
Record: https://patchnext.com/advisories/cve-2023-6236 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.wildfly.security:wildfly-elytron-http-oidc 2.2.5.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.wildfly.security:wildfly-elytron-http-oidc: affected < 2.2.5.Final; fixed in 2.2.5.Final

## Suggested inspection (read-only)
- Maven org.wildfly.security:wildfly-elytron-http-oidc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.wildfly.security:wildfly-elytron-http-oidc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jpmx-996v-48fm (GitHub-reviewed advisory GHSA-jpmx-996v-48fm lists affected ranges: Maven org.wildfly.security:wildfly-elytron-http-oidc >=0 <2.2.5.Final)

Commands are suggestions: review each one before running it.

Loading voting…