OpenStack improperly deletes access rules
CVE-2023-6110GHSA-2ppf-2m6f-6v6f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-openstackclient 6.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 6.3.0
- Fixed in
- 6.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2ppf-2m6f-6v6f lists affected ranges: PyPI python-openstackclient >=0 <6.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2ppf-2m6f-6v6f lists affected ranges: PyPI python-openstackclient >=0 <6.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2023-6110: 0.52% estimated exploitation activity in the next 30 days; percentile 44.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in OpenStack. When a user tries to delete a non-existing access rule in it's scope, it deletes other existing access rules which are not associated with any application credentials.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2ppf-2m6f-6v6f
- Revision 1 · created ·
Published from osv record GHSA-2ppf-2m6f-6v6f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-6110 Advisory: OpenStack improperly deletes access rules IDs: CVE-2023-6110, GHSA-2ppf-2m6f-6v6f Record: https://patchnext.com/advisories/cve-2023-6110 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-openstackclient 6.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-openstackclient: affected < 6.3.0; fixed in 6.3.0 ## Suggested inspection (read-only) - `python -m pip show python-openstackclient`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-openstackclient. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2ppf-2m6f-6v6f (OSV record GHSA-2ppf-2m6f-6v6f lists affected ranges: PyPI python-openstackclient >=0 <6.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2ppf-2m6f-6v6f (GitHub-reviewed advisory GHSA-2ppf-2m6f-6v6f lists affected ranges: PyPI python-openstackclient >=0 <6.3.0) Commands are suggestions: review each one before running it.
Loading voting…