Mattermost denial of service vulnerability
CVE-2023-5967GHSA-xvq6-h898-wcj8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 9.0.1, 8.1.3, 8.0.4; github.com/mattermost/mattermost-server/v6 7.8.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 8.0.0, < 8.0.4>= 8.1.0, < 8.1.3>= 9.0.0, <= 9.0.0
- Fixed in
- 8.1.3, 8.0.4, 9.0.1
Go github.com/mattermost/mattermost-server/v6
- Affected
- < 7.8.12
- Fixed in
- 7.8.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xvq6-h898-wcj8 lists affected ranges: Go github.com/mattermost/mattermost-server/v6 >=0 =8.0.0 =8.1.0 =9.0.0 <=9.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2023-5967: 0.51% estimated exploitation activity in the next 30 days; percentile 43.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost fails to properly validate requests to the Calls plugin, allowing an attacker sending a request without a User Agent header to cause a panic and crash the Calls plugin
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xvq6-h898-wcj8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-5967 Advisory: Mattermost denial of service vulnerability IDs: CVE-2023-5967, GHSA-xvq6-h898-wcj8 Record: https://patchnext.com/advisories/cve-2023-5967 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 9.0.1, 8.1.3, 8.0.4; github.com/mattermost/mattermost-server/v6 7.8.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 8.0.0, < 8.0.4; >= 8.1.0, < 8.1.3; >= 9.0.0, <= 9.0.0; fixed in 8.1.3, 8.0.4, 9.0.1 - Go github.com/mattermost/mattermost-server/v6: affected < 7.8.12; fixed in 7.8.12 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xvq6-h898-wcj8 (GitHub-reviewed advisory GHSA-xvq6-h898-wcj8 lists affected ranges: Go github.com/mattermost/mattermost-server/v6 >=0 =8.0.0 =8.1.0 =9.0.0 <=9.0.0) Commands are suggestions: review each one before running it.
Loading voting…