Skip to content

← Actionable
Medium, CVSS 4.8

phpBB's Smiley Pack acp_icons.php main pack vulnerable to cross site scripting

CVE-2023-5917GHSA-gmx8-8rff-qv6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpbb/phpbb 3.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-5917: 0.62% estimated exploitation activity in the next 30 days; percentile 49.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acpicons.php of the component Smiley Pack Handler. The manipulation of the argument pack leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gmx8-8rff-qv6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-5917

Advisory: phpBB's Smiley Pack acp_icons.php main pack vulnerable to cross site scripting
IDs: CVE-2023-5917, GHSA-gmx8-8rff-qv6q
Record: https://patchnext.com/advisories/cve-2023-5917 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpbb/phpbb 3.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpbb/phpbb: affected < 3.3.11; fixed in 3.3.11

## Suggested inspection (read-only)
- Packagist phpbb/phpbb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpbb/phpbb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gmx8-8rff-qv6q (GitHub-reviewed advisory GHSA-gmx8-8rff-qv6q lists affected ranges: Packagist phpbb/phpbb >=0 <3.3.11)

Commands are suggestions: review each one before running it.

Loading voting…