Skip to content

← Actionable
Medium, CVSS 6.5

Moodle Code Injection vulnerability

CVE-2023-5550GHSA-5cvx-cwpx-9rjh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.3.0-rc2, 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.3.0-beta, < 4.3.0-rc2>= 4.2.0, < 4.2.3>= 4.1.0, < 4.1.6>= 4.0.0, < 4.0.11>= 3.10.0, < 3.11.17< 3.9.24
    Fixed in
    4.3.0-rc2, 3.9.24, 4.0.11, 4.1.6, 4.2.3, 3.11.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2023-5550: 1.62% estimated exploitation activity in the next 30 days; percentile 76.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5cvx-cwpx-9rjh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-5550

Advisory: Moodle Code Injection vulnerability
IDs: CVE-2023-5550, GHSA-5cvx-cwpx-9rjh
Record: https://patchnext.com/advisories/cve-2023-5550 (revision 1, source checked 26 Oct 2026, 14:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.3.0-rc2, 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.3.0-beta, < 4.3.0-rc2; >= 4.2.0, < 4.2.3; >= 4.1.0, < 4.1.6; >= 4.0.0, < 4.0.11; >= 3.10.0, < 3.11.17; < 3.9.24; fixed in 4.3.0-rc2, 3.9.24, 4.0.11, 4.1.6, 4.2.3, 3.11.17

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5cvx-cwpx-9rjh (GitHub-reviewed advisory GHSA-5cvx-cwpx-9rjh lists affected ranges: Packagist moodle/moodle >=4.3.0-beta =4.2.0 =4.1.0 =4.0.0 =3.10.0 =0 <3.9.24)

Commands are suggestions: review each one before running it.

Loading voting…