Moodle Exposure of Sensitive Information to an Unauthorized Actor vulnerability
CVE-2023-5545GHSA-26fg-v32r-h663
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.3.0-rc2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- < 4.3.0-rc2
- Fixed in
- 4.3.0-rc2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-26fg-v32r-h663 lists affected ranges: Packagist moodle/moodle >=0 <4.3.0-rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-5545: 0.58% estimated exploitation activity in the next 30 days; percentile 47.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
H5P metadata automatically populated the author with the user's username, which could be sensitive information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-26fg-v32r-h663
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-5545 Advisory: Moodle Exposure of Sensitive Information to an Unauthorized Actor vulnerability IDs: CVE-2023-5545, GHSA-26fg-v32r-h663 Record: https://patchnext.com/advisories/cve-2023-5545 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.3.0-rc2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected < 4.3.0-rc2; fixed in 4.3.0-rc2 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-26fg-v32r-h663 (GitHub-reviewed advisory GHSA-26fg-v32r-h663 lists affected ranges: Packagist moodle/moodle >=0 <4.3.0-rc2) Commands are suggestions: review each one before running it.
Loading voting…