Skip to content

← Actionable
Unratedamended

Tornado vulnerable to HTTP request smuggling via improper parsing of Content-Length fields and chunk lengths

CVE-2023-54397GHSA-qppv-j76h-2rpx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    < 6.3.3
    Fixed in
    6.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2023-54397: 0.38% estimated exploitation activity in the next 30 days; percentile 31.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Tornado interprets -, +, and in chunk length and Content-Length values, which are not allowed by the HTTP RFCs. This can result in request smuggling when Tornado is deployed behind certain proxies that interpret those non-standard characters differently. This is known to apply to older versions of haproxy, although the current release is not affected. Details Tornado uses the int constructor to parse the values of Content-Length headers and chunk lengths in the following locations: tornado/http1connection.py:445 tornado/http1connection.py:621 tornado/http1connection.py:671 Because int("00") == int("+0") == int("-0") == int("0"), using the int constructor to parse and validate strings that should contain only ASCII digits is not a good strategy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qppv-j76h-2rpx

  2. Revision 1 · created ·

    Published from osv record GHSA-qppv-j76h-2rpx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-54397

Advisory: Tornado vulnerable to HTTP request smuggling via improper parsing of `Content-Length` fields and chunk lengths
IDs: CVE-2023-54397, GHSA-qppv-j76h-2rpx
Record: https://patchnext.com/advisories/cve-2023-54397 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected < 6.3.3; fixed in 6.3.3

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qppv-j76h-2rpx (OSV record GHSA-qppv-j76h-2rpx lists affected ranges: PyPI tornado >=0 <6.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-qppv-j76h-2rpx (GitHub-reviewed advisory GHSA-qppv-j76h-2rpx lists affected ranges: PyPI tornado >=0 <6.3.3)

Commands are suggestions: review each one before running it.

Loading voting…