Remotely exploitable denial of service in Rosenpass
CVE-2023-53157GHSA-6ggr-cwv4-g7qg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rosenpass 0.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io rosenpass
- Affected
- < 0.2.1
- Fixed in
- 0.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6ggr-cwv4-g7qg lists affected ranges: crates.io rosenpass >=0 <0.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2023-53157: 0.58% estimated exploitation activity in the next 30 days; percentile 47.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of this crate did not validate the size of buffers when attempting to decode messages. This allows an attacker to trigger a panic by sending a UDP datagram with a 1 byte payload over network. This flaw was corrected by validating the size of the buffers before attempting to decode the message.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6ggr-cwv4-g7qg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-53157 Advisory: Remotely exploitable denial of service in Rosenpass IDs: CVE-2023-53157, GHSA-6ggr-cwv4-g7qg Record: https://patchnext.com/advisories/cve-2023-53157 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rosenpass 0.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io rosenpass: affected < 0.2.1; fixed in 0.2.1 ## Suggested inspection (read-only) - crates.io rosenpass: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rosenpass. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6ggr-cwv4-g7qg (GitHub-reviewed advisory GHSA-6ggr-cwv4-g7qg lists affected ranges: crates.io rosenpass >=0 <0.2.1) Commands are suggestions: review each one before running it.
Loading voting…