Name confusion in x509 Subject Alternative Name fields
CVE-2023-52892GHSA-ff7q-6vwh-v9m4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.33, 2.0.46, 1.0.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpseclib/phpseclib
- Affected
- < 1.0.22>= 2.0.0, < 2.0.46>= 3.0.0, < 3.0.33
- Fixed in
- 1.0.22, 2.0.46, 3.0.33
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ff7q-6vwh-v9m4 lists affected ranges: Packagist phpseclib/phpseclib >=0 =2.0.0 =3.0.0 <3.0.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-52892: 0.38% estimated exploitation activity in the next 30 days; percentile 31.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in Subject Alternative Name fields in TLS certificates are incorrectly allowed to have a special meaning in regular expressions (such as a + wildcard), leading to name confusion in X.509 certificate host verification.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ff7q-6vwh-v9m4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-52892 Advisory: Name confusion in x509 Subject Alternative Name fields IDs: CVE-2023-52892, GHSA-ff7q-6vwh-v9m4 Record: https://patchnext.com/advisories/cve-2023-52892 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.33, 2.0.46, 1.0.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpseclib/phpseclib: affected < 1.0.22; >= 2.0.0, < 2.0.46; >= 3.0.0, < 3.0.33; fixed in 1.0.22, 2.0.46, 3.0.33 ## Suggested inspection (read-only) - Packagist phpseclib/phpseclib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpseclib/phpseclib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ff7q-6vwh-v9m4 (GitHub-reviewed advisory GHSA-ff7q-6vwh-v9m4 lists affected ranges: Packagist phpseclib/phpseclib >=0 =2.0.0 =3.0.0 <3.0.33) Commands are suggestions: review each one before running it.
Loading voting…