Cache poisoning in drupal/core
CVE-2023-5256GHSA-rjqg-3h9m-fx5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 10.1.4, 10.0.11, 9.5.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.7.0, < 9.5.11>= 10.0.0, < 10.0.11>= 10.1.0, < 10.1.4
- Fixed in
- 10.0.11, 10.1.4, 9.5.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjqg-3h9m-fx5x lists affected ranges: Packagist drupal/core >=8.7.0 =10.0.0 =10.1.0 <10.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2023-5256: 0.85% estimated exploitation activity in the next 30 days; percentile 58.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation. This vulnerability only affects sites with the JSON:API module enabled, and can be mitigated by uninstalling JSON:API. The core REST and contributed GraphQL modules are not affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rjqg-3h9m-fx5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-5256 Advisory: Cache poisoning in drupal/core IDs: CVE-2023-5256, GHSA-rjqg-3h9m-fx5x Record: https://patchnext.com/advisories/cve-2023-5256 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 10.1.4, 10.0.11, 9.5.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.7.0, < 9.5.11; >= 10.0.0, < 10.0.11; >= 10.1.0, < 10.1.4; fixed in 10.0.11, 10.1.4, 9.5.11 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rjqg-3h9m-fx5x (GitHub-reviewed advisory GHSA-rjqg-3h9m-fx5x lists affected ranges: Packagist drupal/core >=8.7.0 =10.0.0 =10.1.0 <10.1.4) Commands are suggestions: review each one before running it.
Loading voting…