PaddlePaddle heap buffer overflow in paddle.repeat_interleave
CVE-2023-52309GHSA-8fp7-jwv2-49x9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (paddlepaddle 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI paddlepaddle
- Affected
- < 2.6.0
- Fixed in
- 2.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8fp7-jwv2-49x9 lists affected ranges: PyPI paddlepaddle >=0 <2.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8fp7-jwv2-49x9 lists affected ranges: PyPI paddlepaddle >=0 <2.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
- EPSS
- CVE-2023-52309: 0.54% estimated exploitation activity in the next 30 days; percentile 45.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Heap buffer overflow in paddle.repeatinterleave in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, information disclosure, or more damage is possible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8fp7-jwv2-49x9
- Revision 1 · created ·
Published from osv record GHSA-8fp7-jwv2-49x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-52309 Advisory: PaddlePaddle heap buffer overflow in paddle.repeat_interleave IDs: CVE-2023-52309, GHSA-8fp7-jwv2-49x9 Record: https://patchnext.com/advisories/cve-2023-52309 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: paddlepaddle 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI paddlepaddle: affected < 2.6.0; fixed in 2.6.0 ## Suggested inspection (read-only) - `python -m pip show paddlepaddle`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on paddlepaddle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8fp7-jwv2-49x9 (OSV record GHSA-8fp7-jwv2-49x9 lists affected ranges: PyPI paddlepaddle >=0 <2.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8fp7-jwv2-49x9 (GitHub-reviewed advisory GHSA-8fp7-jwv2-49x9 lists affected ranges: PyPI paddlepaddle >=0 <2.6.0) Commands are suggestions: review each one before running it.
Loading voting…